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EXPERIMENT NO : Lab 5 (Duration : 2 hours)
EXPERIMENT TITLE : RTL-to-Gates Level Synthesis of Counter using Cadence
RTL Compiler
OBJECTIVE : 1. Code a Counter in Verilog and simulate using
Cadence Incisive Simulator
2. Synthesize the RTL codes to gates using

Cadence RTL Compiler
3. Perform Post-synthesis simulation of design
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Exercise 1 : To simulate a 4-Bit Counter in RTL codes.
Use editor, gedit, to view the codes
Use Cadence Incisive Simulator to simulate the design

(i)
(i)

Open a new terminal

and type: pwd

This linux command will show the present working directory.

cd term2

Change directory to “term2”

source cshrc

Run a script file that will setup a proper environment so that various software can

be launched.

right-click> Edit.

Type nclaunch& to start the GUI as shown in Figure 1. Select counter.v and
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Figure 1 NCLaunch Window
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3. Figure 2 shows the verilog code of the counter. It has 4 bits output named as
count. Read the code to gain some understanding about the counter’s behavior. As
you can see, count will only change either at positive-edge of clock or negative-
edge of reset. Close the file.

O Documents x | [Jcounterv x
m 1 module counter (clk, reset, count);
2 input clk, reset;
3 output reg [3:0] count;
4
5 always @(posedge clk or negedge reset)
6 begin
7 if (reset == 0)
8 count <= 0;
9 else
10 | count <= count +1;
11 end
12 endmodule
13
14

Figure 2 Verilog Code for 4-bit Counter

4, Select counter_tb.v and right-click> Edit. Figure 3 shows the test bench. Read the
code to understand the test bench. Replace “XXX” with “BEH” for this exercise.
When the variable BEH is defined, the file “./RTL/counter.v” will be read/included by
the simulator as it contains the module counter to be tested. Save and close the file.

[J Documents % | [Jcounter_tbw x
1 timescale 1lns/10ps

2 "define PERIOD 10

3 "define PERIOD HALF 5

a

5 //comments of BEH, SYN, PAR

6 //RTL verilog --> define BEH

7 //After synt --> define SYN

8 //After P&R --> define PAR

9

1@ //‘************************************************************************
11 Lkkk ks rstudents only need to modify this portilon®kksssskrs s ot
128 define XXX
13 //‘********** S e ok o ok Sk e ok ok ok sk e ok o ok sk sk ok ok ok ok sk ok ok ok e ok ok ok e ok ok ook e ok ok sk ok S ok ke sk ok e ok ke sk ok e ok ok sk ok ok ok ok sk ok
1
150 ifdef BEH

16§ include "./RTL/counter.v"
17 "elsif SYN

18 //directory is wrt where you launch nclaunch

19 “include "./RTL/counter_synt.v"
20 “include "./RTL/typical.v"

21 "else

22 “include "./RTL/counter_pnr.v"
23 “include "./RTL/typical.v"

24 “endif

25

26 module counter_tb;

27 reg clk tb, reset tb;

28 wire [3:0] count_thb;

29 integer i;

30 parameter width=4;

31

32 ul (.clk(clk_tb), .reset(reset_tb), .count(count_tb));

Figure 3 Verilog Code for Test bench
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5. Select counter.v and counter_tb.v (to select, press Ctrl & click on the file, as shown
in Figure 4). Right-click=>NCVlog. Then click OK. This will compile the verilog files to
C code for faster simulation.

O NCLaunch : /DIPLOMA/Year3/EG3010/g4  (term2 (=)(E][x]

File Edit Tools Utilities Plug-lns Help cadence

Erowsers: @”l @l Tools: ﬁ’%@ %l
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u.ﬂ L =
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Bz RTL W Wark Library Iworklib =
3 counter.w® .
Overwrite lag file  — | |ncu|ng.|og |
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) _ | Error Limit 14 =
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I Other Options
Advanced Options... |
QK Cancel apply Help | —
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Figure 4 NCLaunch Window
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6. Select worklib/counter_tb (as shown in Figure 5). Right-click=>NCElab. Then click
OK. This will link up all the related compiled modules for simulation.
=] Elaborate [x|par3/EG3010/g: ‘term2 E==11E.3
Design Unit worklib. counter th cadence
 [libJcellfvisw ) | - ----IE! FRg— ¥
_1 Snapshot Mame | Al IE| connectLib
#-fE  ieee
W Waork Library |w0rk|ib hd ....E‘ ncinternal
Ovenutite log file  — | |nce|ab.log | g :E:;[:els
W Error Limit [ s wol sdilin
EfE st
_i Update if needed w-l synopsys
W access Yisibilit &l | #H  vitamemory
4 -y worklin
_| Executable Filename | | | - A8E  courter
{ Default: ncelah ) _"'
Bl napsnos e
_I Other Optians | ﬂ- /
. mpiling design unit worklib.counter.
Advanced Cptions.. | J
data = £1.2M total i
oK Cancel Apply Help | —
1 items selected
Figure 5 NCElab Window
7. Select Snapshots/worklib.counter_tb:module (as shown in Figure 6). Right-

click>NCSim. Then click OK. This will allow you to setup the environment for

simulation.
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Figure 6 NCSim Window

Select counter_tb (as shown in Figure 7). Right-click=>Send To New—> Waveform

Window. The related signals of counter_tb will be probed for display.
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Figure 7 SimVision/Design Browser Window

IC Layout Design Project [EG3367] Lab 5 - Page 6 Effective Date : 17 Apr 2017



9. Select count_tb[3:0] (the output of counter as shown in Figure 8). Simulation=>Run.
Then View—>Zoom->Full X. Use the Sliding Bar and View—>Zoom—2>1n X (or Alt-i) to
zoom in to count_tb[3:0]=F as shown. Click on the waveform screen to bring TimerA
to clock edge as shown. There is no delay between the positive-edge of clk_tb and
output of counter since the counter is modeled by verilog behavioral code.

Fa Waveform 1 - SimVision E]@E]
Eile Edit Miew Explore Format Simulation Windows Help cadence
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Figure 8 SimVision/Waveform Window

10. Exit all the software.
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Exercise 2: To synthesize the 4-Bit Counter, of Exercise 1, using Cadence Software — RTL
Compiler.

1. Open a new terminal and type:
pwd
If you’re not in your home directory, do a c¢d ~ to change to your home directory
BAX_XX.
cd term2
source cshrc
cd RC

2. Type rc to launch the RTL Compiler. You should see the RC-shell prompt as shown in
Figure 9.

Terminal

FHle Edit Wiew Terminal Tabs Help

Send us Teedback at rc_fTeedback@cadence.com.

e D)

Figure 9 RC-shell Prompt

3. Type:
source counter.tcl
counter.tcl contains the instructions for the setup of various libraries, constraints
and etc. for the software to produce the netlist from your behavioral verilog code.
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4, Type:
gui_show
This will show you the schmatic of the synthesized circuit. 4 registers, 2 gates and 1
inverter are used to realise the function of the 4-bit counter.

File Report Tools Preferenceg Window Help cadence

I
Hierarchy | HDL ( Schematic
-l A Q Q ™
=1 ola Q&

IQE"-’|U(;\ 1

Figure 10 Schematic

5. Close the window. You can type gui_hide to close the window.
Type exit to exit RTL Compiler.

6. Type:
pwd to know which directory you are in.
You can cd .. to go up to the parent directory or c¢d ~ to your home directory if you
get lost.
Make sure you are in .../term2/RC, type more counter.tcl to view the setup of the
synthesis run you have just performed. A lot of knowledge and expertise are
required to do a synthesis for complex digital circuit. Use space bar key to scroll
throught the file.

7. The synthesized netlist file is in .../term2/RTL.
Go to that directory and do a more counter_synt.v to view the netlist. You can see
the 7 gates used for the 4-bit counter.
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This exercise is optional:
Exercise 3: Post-synthesize simulation using Cadence Incisive Simulator

1. Type:
cd..togoupto../term2.
nclaunch&

2. Right-click>Edit on counter_tb.v
Change the variable to SYN as shown in Figure 11. Save and close the file.
typical.v is the standard cell library that contains the modules of the gates that we’re
going to use.

counter_tb.v (~/term2/RTL) - gedit

File Edit View Search Tools Documents Help

2 .d &9 0 B ¥
New Open Save Print... Undo Paste Find Replace
[J Documents x | [Jcounter tbv x

1 timescale lns/1@ps

2 “define PERIOD 10
3 "define PERIOD_HALF 5
4

5 //comments of BEH, SYN, PAR, ANNOTATE
6 //RTL verilog --> define BEH

7 //After synt --> define SYN

8 //After P&R --> define PAR

9

11 f/rkArk students only need to modify this portiont#kkboksorsbdofdod ok kok
12 “define|SYN|

14

15 "ifdef BEH

16 "include " /RTL/counter.v"

17f elsif SYN

18)//directory is wrt where you launch nclaunch

19 “include "./RTL/counter_synt.v"
20| “include "./RTL/typical.v"

21 €TsE

2 “include "./RTL/counter_pnr.v"
23 “include "./RTL/typical.v"

24 “endif

Figure 11 Test Bench
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3. We are going to simulate the test bench like what we did in Exercise 1. Refer to it if
you not sure.
Select counter_synt.v, counter_tb.v and typical.v and right-click>>NCVlog (Figure
12).
Note : This may take a while for the typical.v file to be compiled.

Eile Edit Tools Utilities Plug-lns  Help cadence
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----[m RC """ [l connectLib
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""ﬂ hCutils
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F-{#l  constraints ""ﬂ std
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nclaunchz=
| 3 items selected
Figure 12 NCLaunch Window
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4, Select worklib/counter_tb and right-click> NCElab.
Select Snapshot/worklib.counter_tb:module and right-click>NCSim.
Select counter_tb and right-click>Send To New—>Waveform Window.
Select count_tb[3:0]. Simulation=>Run.
Zoom in to count_tb[3:0]=F as shown in Figure 13.
Click on waveform to bring TimerA to the desired location.
Right-click-> Create a marker to put additional marker.

Waveform 1 - SimVision -8

Eile Edit ¥iew E=plore Format Simulation Windows Help cadence

B EE]E:_"; Y S :E"]-‘ t-||E- mm @, s SendTo:'E% ﬁ »

Search Mames: | Signal = [~ fi || Search Times: | ¥alue » ﬂ%%\, ?;%\»
—— =T L oo o -
el DR FELEL L

& Bageling =0 Aarker 1 = 155,150ps ™
h FF| Cursor-EBaseline == 155,000ps

Mame = Cursar =

o

S| Cursor: Times Primary cursor for 2 windows 0 objects selected
Figure 13 SimVision/Waveform Window

5. As you can see, there is delay of 150ps between postive-edge of clk_tb and counter’s
output. This is due to the gate delay since now we are simulating a real circuit.
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Exercise 1

To do place and route of the counter synthesized in previous lab using Cadence software -

Encounter.

1. Open a new Terminal. Type :

pwd
cd
cd term2

source cshrc

(show present working directory)
(change directory to home directory)
(change driectory to term2 directory)

(execute a setup file called cshrc)

2. Change directory. Type :

cd EN

encounter to launch the software. You should see Figure 1.

= Encounter(R) RTL-to{ = Terminal [Se)]]  [=l=)kx]
File Edit View Pariion Floomlan | File Edit View Terminal Tabs Help _|cadence
f ‘ G4 gg| **INFO:  MMMC transition support version v31-82
_c%}c ok g 1 @ [|encounter 1> [] el B
Layer Control 53

_All Calars
Enstance Y
Instance L4Ca =
S
Block r
Std. Cell v
Cover Cell M=
[ world view &0

Click to select single ohject. Shift+Click to desselect multiple ohjects. Q| |SelNum:d [-0013, 0112) Mot in Memory

Figure 1 Encounter-shell Prompt

3.

In Encounter GUI, File>Import Design.

As shown in Figure 2, click Load, select counter.globals and click Open. Click OK to

import the design.

- Design Import B
Hetlist:
& Verilog
iles: /RTL/counter_syntv
Op Cell o Auto Assign @ By User: counter
— 0
Technology/Physical Libraries:
~ DA
® LEF Files JLEF/st_gsclib045.1er
Floorplan
10 Assignment File: [
Power
Fower Nets: ¥DD
Ground Nets: V35
CPF File |
Analysis Configuration
MMM Yiew Definition File: eg3010.view [

_Create Analysis Configuration ... |

< i Load ) _Cancel

Figure 2 Import Design

_ Help

Save
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4.

Eile Edit View Parliion Floorplan Pouer Flace Qptimize Clock Route Timing Verfy Opfions PVS Tools Flows

Hit f to see the full view. Click on the icon (red cycle) as shown in Figure 3.

Help cadence

[
a

(= | @ |EEEhd P £ WY |Q Q&
(b O % B @ 1 &M% =& 40

Al Colors
B Instance
Instance
Elock

Std. Cell
Cover Cell
Physical Cell
10 Cell

[Area 10 Cell
Black Box

Rk [ KRR KR KR KRR R R] <

L

Congestion
Multiple Color
 Miscellaneous

B Wire&¥ia
Poly{ho)
Cont(v01)
Metalt (b1

K
Click to select single ohject. Shift«Click to desselect multiple abjects. Q [Sellumd (8527, 7.215)

Figure 3 Ready for Floorplanning

Floorplanning:

viat(12)

in Memary _[

Floor plan—>Specify Floorplan. Key in the parameters as shown in Figure 4 and

click OK.

] Specify Floorplan (==l
Basic | Adwvanced
Design Dimensions
Specify By: & Size o DiedC/Core Coordinates
& Core Size by: & Aspect Ratio: Ratio (HW): 1
& Core Utilization: 0.6
— Cell Utilization:
— Dimension:
— Die Size hy:
Care Marging by @ Core to 10 Boundary
Core to Die Boundary
I—
Core to Left: 10.0 Core to Top: 10.0
Core to Right: 10.0  Core to Bottom: 10
Die 5ize Calculation Use: 0 Max 10 Height ® Min 1D Height
Floorplan Crigin at: & Lower Left Corner o Center
Unit: kicran
[ oK ] _Apply _Cancel _ Help

Figure 4 Floorplanning
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6. We are going to add 2 supply rings for VDD and VSS.
Power>Power Planning>Add Ring. Key in the parameters as shown in Figure 5 and

click OK.
C Add Rings B
Basic  Advanced  Via Generation
MNetis): VDD V5SS ] ‘
Ring Type
& Core ring(s) cantauring
& Around core boundary  Along KO houndary
— Exclude selected objects
« Block ring(s) around
® Each hlock
Each reef
Selected power domain/fences/reefs
Each selected block andfor group of core rows
Clusters of selected blocks andfor groups of core rows
wWith shared ring edges
 User defined coordinates IdouseElick
® Care ring Elock ring
Ring Configuration
Tap: Bottom Left: Right
el el 1ol bl el
Wicith 4 4 4 4
Spacing: 0.8 0 0d 0 Update
Offsetd @ Center in channel? Iu Specify
0165 0165 0165 0.165
Option Set
‘ (it R Stinn
Set Mode Apply Defaults Cancel Help
Figure 5 Add Power Ring
7. The layout should be the same as shown in Figure 6. It is time to save the work thus
far. File->SaveDesign, check Encounter and call it stepl.enc
Click OK.
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] Encounter(R) RTL-to-GDSII { ] Save Design =y term2/EN - counter E]@E]
File Edit View Parition Floorplan Power | Data Type: ® Encounter _ DA Tools Flows Help cadence
— | File Name: stepilenc i . e
£l s ¢ |0 bdzERl k& % IE N @ &

J = U Hierarchical DB J J
] s S8l 1 B Dy oW N ) .|

_All Colors
Hinstance
Instance
Block

Std. Cell
Cover Cell
Physical Cell
10 Cell
Area |0 Cell
Elack Box
Elack Blab
FHModule
FHHet

EH Cell

FH Blockage
HRow

EH Floorplan
EH Partition
EHBump
FHPower

Cancel

C

[ KRR KR
L L L L L L O L L T L L 4

=]
x| |

FH Grid

Word View

Click to select single abject. Shift+Click to desselect multiple ohjects. Q ||SelMum:D |-6.472,18.907) |\n Memary

Figure 6 Save Design

8. Before we proceed further, we need to instruct Encounter to connect signals VDD or
VSS, and signals that connect to logic high or logic lew, te supply ring VDD and VSS
respectively. This can be done via the Enceunter-shell as shown in Figure 7.

After typing and finish the first line of command, hit ENTER. To save effort in typing,
hit UP Arror Key to bring up the previous command for modification. Key in the 4
commands as shown in the figure.

i e e i w et e m e oy w2 mowow o ow e = fm e w e memoaw =

0.000M) **x*

encounter 1> globalNetConnect VDD -type pgpin -pin VDD -all
encounter 2> globalNetConnect VSS -type pgpin -pin VSS -all
encounter 3> globalNetConnect VDD -type tiehi

encounter 4> globalNetConnect VSS -type tielo

encounter 5> JJ

Figure 7 Power Pins Connection

9. Gates are placed in the layout row-by-row. We need to provide supply rails for them.
Route—>Special Route. Key in parameters as shown in Figure 8.

IC Layout Design Project [EG3367] Lab 6 - Page 5 Effective Date : 17 Apr 2017



- SRoute [l

Basic | Advanced  Via Generation

(s VDD Y53
& Block Pins & Pad Pins & Pad Rings & Follow Pins Secondary Power Ping
Routing Control
Layer Change
Top Lafgr Bottam Layer: | Metall »
» Allow Jogging # Allow Layer Change
__ Area Power Domain Selection
X1 Nk Draw, & All
\i—
X2 ¥e YigwAres — Selected
~ Mamed:

Connect to Target Inside The Area Only
_ Delete Existing Routes
_ Generate Progress Messages
__ Extra Config File: _I _Extra Config Editing

_Target Editing Options

m _Apply _Defaults _Cancel __Help

Figure 8 Supply Rails for Cells

10. Perform placement:
Place>Place Standard Cell. The cells should be placed as shown in Figure 9. If not,

View=>Redraw.

Figure 9 Placement

11. Routing
Route—> Nanoroute—->Route to complete the routing.
Place>Physical Cell=>Add Filler and select FILL1, FILL1A, FILL2, FILL4, FILL8 as
shown in Figure 11, by using Ctrl + Click and Add. This will fill up the empty space.
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Add Filler

Prefix FILLER

Power Damain Select
_ Mo DRC
_ Mark Fixed
— Fill Area [Dra, Wi Area,
13 ly
LR ury

m Apply tode cancel Help

Figure 10 Add Filler

12. File->Save Netlist.
Navigate to ../RTL and provide file name of counter_pnr.v
The netlist will be saved as ../RTL/counter_pnr.v

O Save Netlist (=I=lx]

# Include Intermediate Cell Definition

¥ Include Leaf Cell Definition p——

Metlist File: /RTL/counter_pnry ‘ Ir'?l
m Cancel Help

Laook in: [E8l /DIPLOMAS Y eard/EGI0T 0/ termz/RTL Q L =1 =S|
=] Compu... Mame -~ | Bize | Type |Date Modified |

[ countery 2dl..tes v File £d Dec .7:a3743

[ countery- 222, tes  w~ File 26 Sep 0:03:06

[ counter_synty g09..tes v File 29 Dec ..0:459:36

[ counter_thy 1 KB v File 29 Dec ..1:03:03

[ counter_thy- 1 KB v~ File 28 Dec ..7:36:47

[ typicaly 394 KE v File 31 Jul1a0:28

ﬂ
File name: ‘ counter_prry] 3
Files of type: Werilog Files (. Lancel

Figure 11 Save Netlist
13. Timing—>Extract RC (as shown in Figure 12) to extract R and C of all the wires.

= Extract RC Elli=llEs

Save RC

Save Setload to counter setload

— Save Set Resistance to  counter.setres |

| Save 5PF to  counter.spf

» Save SPEF to counterspef Ir'fl
RC Corner to Output  typl

m Apply | Cancel | Help ‘

Figure 12 RC Extraction
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14. From the Extracted RC file, a file that describes delay of all the wires can be
produced.
Timing—> Write SDF.
As shown in Figure 13, change to directory RTL and provide a file name of
counter.sdf
Click Save and then OK.
We are ready to simulate the circuit again with the delay of wires included. You can
exit all software.

El Calculate Delay E]@E]l

Delay Calculation Option

¥ |deal Clock

SDF Qutput File: = |
Apply Cancal Help ‘

Look in: [E5/DIPLOMASY eardEG3NT 0 Q =0

[=] Campu Marme ~ |Size |Type |Date Modified |

—
File nar‘. counter.sdi ,

Files of type: Delay Files {".3df) n Cancel

4

Figure 13 Delay Calculation

14. This is the complete layout produce by the software.
File>SaveDesign to counter.enc
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Exercise 2: Post-layout simulation

1. We are going to simulate the circuit again but this time with all the delay of wiring
(post-layout) taken care of. Refer to Lab5 Exercise 1 if you are not sure about the
commands of the simulator.

2. Type :
cd
cd term2
source cshrc
nclaunch&

3. Select RTL/counter_tb.v and right-click->Edit.
For the statement “define XXX”, replace it with “define PAR”. Save and close the file.
Select counter_pnr.v and counter_tb.v and right-click>NCVlog.

4, Select worklib/counter_tb and right-click->NCElab.
Select Snapshot/worklib.counter_tb:module and right-click=>NCSim.
Select counter_tb and right-click=>Send To New-> Waveform Window.
Select count_tb[3:0]. Simulation=>Run.
Zoom in to count_tb[3:0]=F as shown in Figure 14.
Click on waveform to bring TimerA to the desired location.
Right-click-> Create a marker to put additional marker.

1 Waveform 1 - SimVision E]@E
File Edit Miew Explore Farmat Simulation Windows Help cadence

% b e xhi x| @ i~ || || $+FrRERBHEEE

Search Names: | Signal » B & §f | search Times: | Value - B
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Figure 14 Result

5. As you can see, there is delay of 290ps between postive-edge of clk_tb and counter’s
output. This is due to the gate delay and wire delay, since now we are simulating a
post-layout netlist.
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EXPERIMENT NO : Lab 7 (Duration : 2 hours)
EXPERIMENT TITLE : Place and Route of Shifter using Cadence Encounter

OBJECTIVE : To perform place and route of Shifter
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Exercise 1

To do place and route of the Shifter synthesized in Lab9 using Cadence Encounter

1.

Open a new Terminal
Type :
cd
cd term2
source cshrc
Change directory
Type :
cd EN
encounter to launch the software.
In Encounter GUI, File>Import Design.
Click Load, select shifter_top.globals and click Open. OK to load the design.
Floorplanning:
Floor plan—>Specify Floorplan.
Ratio=1, Core Utilization=0.6, Core to Left/Right/Top/Bottom=10.
click OK.
We are going to add 2 supply rings for VDD and VSS.
Power—>Power Planning=>Add Ring.
Nets: VDD VSS
Width=4, Spacing=0.8, Center in Channel.
Click OK.
Before we proceed further, we need to instruct Encounter to connect signals VDD or
VSS, and signals that connect to logic high or logic low, te supply ring VDD and VSS
respectively.
This can be done via the Encounter-shell as shown in Figure 1. Hit ENTER if there is
no encounter prompt.
0.000M) **x*

encounter 1> globalNetConnect VDD -type pgpin -pin VDD -all
encounter 2> globalNetConnect VSS -type pgpin -pin VSS -all
encounter 3> globalNetConnect VDD -type tiehi

encounter 4> globalNetConnect VSS -type tielo

encounter 5> [

Figure 1 Power Pins Connection
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10.

11.

Gates are placed in the layout row-by-row. We need to provide supply rails for them.
Route—>Special Route.

Nets: VDD VSS

Top Layer: Metal5

Perform placement:
Place—~>Place Standard Cell.

Routing:

Route—> Nanoroute—>Route to complete the routing.

Place->Physical Cell>Add Filler and select FILL1, FILL1A, FILL2, FILL4, FILLS
The complete layout produce by the software is shown in Figure 2.
File=>SaveDesign to shifter_layout.enc

Maximize the layout window. Hit Print_scrn to save the screen/result as
shifter_layout.png in the desktop.

Figure 2 Complete Layout

File>Save Netlist to save the netlist as ../RTL/shifter_top_pnr.v

Timing—=>Extract RC. Remember to check ‘save SPEF ...".

Timing—> Write SDF. Name the file as ../RTL/shifter_top_pnr.sdf (in /RTL directory).
We are ready to simulate the circuit again with the delay of wires included.

You can exit all the software.
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Exercise 2: Post-layout simulation

1. Type:
cd..togoupto../term2.
nclaunch&

2. Right-click>Edit on RTL/shifter_top_tb.v
Change the variable to PAR.
Save and close the file.

3. Select shifter_top_pnr.v, shifter_top_tb.v and typical.v and right-click>NCVlog
Note : This may take a while for the typical.v file to be compiled.

4, Select worklib/shifter_top_tb and right-click->NCElab.
Select Snapshot/worklib.shifter_top_tb:module and right-click->NCSim.
Select shifter_top_tb and right-click->Send To New—>Waveform Window.
Simulation>Run.
Click on waveform to bring TimerA to the desired location.
Right-click>Create a marker to put additional marker.

Waveform 1L - SimVision
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Figure 3 Result

5. As you can see, there is a delay of 280ps between postive-edge of clk and shifter’s
output (when signal dig_1[6:0] finally settled). This is due to the gate delay and
wiring since now we are simulating a post-layout circuit.

6. Maximize the waveform window. Hit Print_scrn to save the screen/result as
shifter_waveform.png in the desktop.
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